Java support

This functional testing application supports the following Java™ versions for testing Java applications and HTML applications with applets.
Table 1. Java support
32-bit mode 64-bit mode
  • IBM JRE 1.4
  • IBM JRE 1.5
  • IBM JRE 1.6
  • IBM JRE 1.7
  • IBM JRE 1.8
  • SUN JRE 1.3 (Only on Windows for stand-alone Java applications)
  • Sun JRE 1.4
  • Sun JRE 1.5
  • Sun JRE 1.6
  • Oracle JRE 1.7
  • Oracle JRE 1.8
  • IBM JRE 1.7
  • IBM JRE 1.8
  • Sun JRE 1.5
  • Sun JRE 1.6
  • Oracle JRE 1.7
  • Oracle JRE 1.8
  • Oracle JRE 9
  • Oracle JRE 10
  • Oracle JDK 11
Note: HTML applications with applets can be tested in Java 8 and earlier but this is not supported in Java 9 and later.

For specific information on the recommended versions that are validated and have provided optimal results, refer the technical document available at Software Product Compatibility Reports

Note:
  • HCL OneTest™ UI does not support testing applications that are running in Java runtime environments with green threads enabled.
Feedback