Proxy development environment

HCL OneTest™ UI proxies can be developed either in Java™ or C# programming languages based on the UI framework of the application under test (AUT).

You must use Java for developing proxies for the following UI frameworks under Java and HTML domains:

You must use C# for developing proxies for UI frameworks under the following domains:

Software requirements

You must have the following software in you computer to develop proxies using the proxy SDK
  • HCL OneTest UI 9.1 or later.
  • Eclipse 3.2 or later, or any other JDK for developing proxies in Java
  • Microsoft Visual Studio.Net for developing proxies in C#. For developing ProxyObjects, you must use one of the following integrated development environments:
    • Visual Studio .Net 2010 for .Net 4.0 controls
      Note: Microsoft Visual Studio.NET 2010 is installed with Microsoft .NET Framework 4.0. To use HCL OneTest UI with the Visual Studio.NET 2010 Integrated Development Environment, you must also install Microsoft .NET Framework 2.0, 3.0 or 3.5.
Note: ProxyObject is exposed to the scripting side of HCL OneTest UI as either .Net or Java TestObject, depending on the test scripting choice.
Feedback