HCL OneTest UI menus

This topic describes all the options and commands on the HCL OneTest™ UI menu.

HCL OneTest UI has the following menus:

File

Edit

Source

Refactor

Navigate

Search

Project

Script

Configure

Run

Window

Help

File menu

The File menu has the following commands:

New -- Displays the appropriate dialog box that enables you to create a new project, Functional Test project, record a Functional Test script, Functional Test empty script, test folder, test dataset, test object map, helper superclass, or to use all wizards other than project wizards.

Connect to a Functional Test project -- Displays the Connect to a Functional Test project dialog box, which enables you to specify the project you want to use and its location. You must first connect to an existing Functional Test project before you can use it.

Open File -- Displays the Open File dialog box, which enables you to open a file that is not part of a Functional Test project.

Close -- Closes the script currently displayed in the Java Editor.

Close All -- Closes all the scripts that are open in the Java Editor.

Save script -- Saves any changes you made to the script currently displayed in the Java Editor.

Save Script " script " As -- Displays the Save Script As dialog box, which enables you to save the current Functional Test script under another name.

Save As -- Displays the Save As dialog box, which enables you to save the current file under another name and location.
Note: Do not use this option to save scripts.

Save All -- Saves all the scripts and files currently open.

Revert -- Reverts the contents of the script back to the previous saved version.

Move -- Enables you to move the selected editor or tab group.

Rename -- Displays the Rename dialog box, which enables you to save the script with a different name.

Refresh -- Refreshes the contents of the currently active script to reflect changes.

Convert Line Delimiters To -- Enables you to see the line delimiters in default view (Windows), or convert to either Unix or MacOS 9.

Print -- Displays the Print dialog box, which enables you to print the currently active script.

Switch Workspace -- Displays the Select a workspace dialog box, which enables you to store projects in a different directory only for the current session.

Restart

Import -- Displays the Import wizard, which enables you to copy files from an external source into projects. For information, see the online Workbench User Guide.
Note: Functional Test supports two import types: Functional Test project items and Functional Test datasets.

Export -- Displays the Export Wizard, which enables you to export resources from projects to an external source. For information, see the online Workbench User Guide. Note: Functional Test supports two export types: Functional Test project items and Functional Test datasets.

Properties -- Displays the HCL OneTest UI Project Properties page page if you have selected a Functional Test project, or the HCL OneTest UI Script Properties page, if you have selected a script.

Project filenames -- Displays the names of projects you have most recently used.

Exit -- Closes HCL OneTest UI.

Edit menu

The Edit menu has the following options:

Undo -- Cancels the last edit you made, if possible. Some edits cannot be undone.

Redo -- Does the action of the last Undo action again.

Cut -- Deletes the highlighted characters and puts them on the Clipboard.

Copy -- Copies the highlighted characters to the Clipboard.

Copy Qualified Name -- Copies the fully qualified class name of the custom helper superclass, if any, in the selected script, to the Clipboard.

Paste -- Inserts at the cursor any characters that were previously cut or copied to the Clipboard.

Delete -- Removes the highlighted characters.

Select All -- Highlights all the characters in the currently displayed script or file.

Expand Selection To -- Enables you to quickly select Java code in a syntax-aware way. For information, see the online Java Development User Guide.

Find/Replace -- Displays the Find/Replace dialog box, which enables you to search for a string of text in a script and substitute an alternate string.

Find Next -- Finds the next occurrence of the text selected in the Java Editor.

Find Previous -- Finds the previous occurrence of the text selected in the Java Editor.

Incremental Find Next -- Finds the next occurrence of the text you type. For information, see the online Java Development User Guide.

Incremental Find Previous -- Finds the previous occurrence of the text you type. For information, see the online Java Development User Guide.

Add Bookmark -- Displays the Add Bookmark dialog box, which enables you to insert a marker that points to a specific place in a script or file.

Add Task -- Displays the New Task dialog box, which enables you to associate a task with a specific location in a resource. For information, see the online Java Development User Guide.

Smart Insert Mode -- Toggles Smart Insert Mode on and off.

Expand Selection To -- Enables you to quickly select Java code in a syntax-aware way. For information, see the online Java Development User Guide.

Show Tooltip Description -- Displays the value of a hover that would appear at the current cursor location. For information, see the online Java Development User Guide.

Content Assist -- Assists you when writing Java code or Javadoc comments. For information, see the online Java Development User Guide.

Quick Fix -- Displays solutions for certain problems underlined with a problem highlight line. For information, see the online Java Development User Guide.

Word Completion -- Enables you to auto-complete names of elements in your script syntax. For information, see the online Java Development User Guide.

Parameter Hints -- Displays parameter type information. For information, see the online Java Development User Guide.

Set Encoding -- Changes the encoding of the currently shown text content to Default (inherited from container: CP1252), CP1252, ASCII, Latin 1, UTF-8, UTF-16 (big-endian), UTF-16 (little-endian), UTF-16, or Others. For information, see the online Java Development User Guide.

Source menu

The Source menu contains Eclipse commands that are not applicable to HCL OneTest UI.

Refactor menu

The Refactor menu contains Eclipse commands that are not applicable to HCL OneTest UI.

Navigate menu

The Navigate menu contains Eclipse commands that are not applicable to HCL OneTest UI.

Project menu

The Project menu contains Eclipse commands that are not applicable to HCL OneTest UI.

Script menu

The Script menu has the following options:

Run -- Plays back the Functional Test script currently displayed in the Java Editor. For information see Running a Script from Functional Test.

Debug -- Launches the current script and displays the Test Debug Perspective, which provides information as the script debugs. For information, see Debugging Scripts.

Add Script Using Recorder -- Record a Functional Test script.

Insert Recording -- Starts recording at the cursor location in the current script, which enables you to start applications, insert verification points, and add script support functions.

Open Test Object Map -- Displays the test object map associated with the script currently displayed in the Java Editor.

Update Script Helper -- Updates the script's helper file (*ScriptHelper.java) to reflect changes made to the template for the selected test asset.

Insert Verification Point -- Displays the Select an Object page of the Verification Point and Action Wizard, which enables you to select an object in your application you want to perform a test on.

Insert Test Object -- Displays the Select an Object dialog box, which enables you to select test objects to add to the test object map and a script.

Insert Data Driven Commands -- Displays the Data Drive Actions page of the dataset Population wizard, which enables you to select the objects in an application-under-test to data-drive an application.

Find Literals and Replace with dataset Reference -- Replaces literal values with a dataset reference in a test script to add realistic data to an existing test script.

Configure menu

The Configure menu has the following options:

Configure Applications for Testing -- Displays the Application Configuration Tool, which enables you to add and edit configuration information -- such as name, path, and other information that HCL OneTest UI uses to start and run the application -- for the Java and HTML applications you want to test.

Enable Environments for Testing -- Displays the Enable Java Environments (JRE) / Web Browsers / Eclipse Platforms for Testing dialog box, which you use to enable Java environments and browsers and to configure your JREs and browsers.

Configure Object Recognition Properties -- Displays the Object Properties Configuration Tool, which enables you to Object Properties Configuration Tool.

Configure Unexpected Windows -- Displays the Configuring how to handle unexpected windows during playback, which enables you to configure how unexpected windows that open during script playback can be handled, to ensure smooth playback.

Run menu

The Run menu contains Eclipse menu items that are not applicable to HCL OneTest UI except for the Test Object Inspector menu item.

Test Object Inspector -- Displays test object information, such as parent hierarchy, inheritance hierarchy, test object properties, nonvalue properties, and method information.

Window menu

The Window menu contains Eclipse menu items that are not applicable to HCL OneTest UI except for the Open Perspective and Preferences menu items.

Open Perspective -- Open a another perspective in the HCL OneTest UI Debug window. For information, see the online Workbench User Guide.

Preferences -- Displays the HCL OneTest UI Preferences page, which enables you to customize Functional Test by setting preferences for HCL OneTest UI, Highlight, Logging, Operating System, Playback, Playback Delays, Playback Monitor, ScriptAssure(TM)-Standard, Script Assure(TM)- Advanced, Recorder Preferences, Recorder Monitor Preferences, Workbench Preferences for HCL OneTest UI, and Workbench Advanced Preferences for HCL OneTest UI. You can also display the Team Preferences page, which enables you to set preferences for Clear Case.

Help menu

The Help menu has the following options:

Welcome -- Displays the Welcome to HCL Products page, which contains information that will help familiarize you with HCL OneTest UI.

Help Contents -- Displays the online HCL OneTest UI table of contents and information, which you can use to navigate to various topics.

Search -- Displays the Search page, which enables you to search the Product help.

Dynamic Help -- Displays Java specific text editing support information.

Index -- Displays the HCL OneTest UI index.

Key Assist -- Display a list of keyboard shortcuts that you can use while working with HCL OneTest UI.

Tips and Tricks -- Display tips and tricks for Eclipse Java Development tools, Eclipse platform, and Eclipse plug-in development environment.

Functional Test Help -- Displays the online HCL OneTest UI table of contents and information.

Functional Test Proxy SDK -- Displays the HCL OneTest UI proxy software development kit (SDK) help.

Functional Test API Reference -- Displays an overview of the online Functional Test API Reference Guide, which you can use to navigate to various topics.

Web Resources -- Displays troubleshooting and support information that will enable you to fix problems and find additional resources.

Cheat Sheets -- Displays the cheat sheets for using HCL OneTest UI.

Process Advisor -- Displays best practices and guidance that will help you learn how to create projects and test scripts using HCL OneTest UI.

Process Browser -- Displays best practices topics and tasks from the Process Advisor.

Manage Licenses -- Displays the Manage Licenses dialog box which will help you to apply licenses, or update your license status.

Check for Updates and Install New Software-- Enable you to update products and to download and install new features. Manage the configuration of HCL OneTest UI. Scan for updates for all installed features, add an extension location, view installation history, and show activities that caused the creation of the configuration. For information, see the online Workbench User Guide.

IBM Installation Manager -- Displays IBM Installation Manager, which you can use to install, update, modify, roll back or uninstall software.

HCL OneTest UI -- Displays information about the current version of the HCL OneTest UI you are running.

Feedback