Solution explorer

The Solution Explorer, which is the right pane of the Visual Studio .NET window, provides an organized view of your projects and their files.

The Solution Explorer displays:

Projects icon Projects

Object Map icon Object maps

Script icon Scripts

Folder icon Folders

Log Folder icon Log folders

Log icon Logs

The Solution Explorer toolbar has the following buttons:

The View Code button View Code button opens the selected script for editing in the Code Editor.

The Refresh button Refresh button updates the Solution Explorer display with information from the database.

The Show All Files button Show All Files button displays all the project items for the selected project, including those that have been excluded and those that are normally hidden.

The Properties button Properties button displays the properties for the selected item in the appropriate window.

Double-clicking a script in the Solution Explorer opens the script in the Code Editor.

Right-clicking on a project or test asset listed in the Solution Explorer displays various menu options, which are listed here in alphabetical order:

Add Empty Script -- Enables you to create a script without recording, which you can use to add VB.NET code.

Add Script Using Recorder -- Enables you to enter information about the new script and start recording.

Add Solution to Source Control -- Enables you to add a solution to source control. The solution must be created in a ClearCase VOB for this menu item to appear on the menu. HCL OneTest™ UI ClearCase adds all test elements in the solution to source control.

Add Test Datapool -- Enables you to create a new test datapool.

Add Test Object Map -- Enables you to add a new test object map to a project.

Check In -- Enables you to add one or more test elements to source control.

Debug -- Compile and run the Rational® Test script.

Delete -- Enables you to delete the selected test folder, test object map, test datapool, log, or script.

Failed Verification Points -- Opens the selected verification point actual results file in the Verification Point Comparator, where you can compare and edit the data. See About Logs.

Final Screen Snapshot -- Available when the log of a script that failed on its last run is selected. Opens the screen snapshot image taken at playback failure. See Screen snapshot on playback failure.

Export -- Enables you to export project items for the selected project.

Import -- Enables you to import project items for the selected project.

Insert as "CallScript" -- Available when a script is selected, inserts the CallScript ("scriptname") code in the current script at the cursor location. See Calling a Script from a Functional Test Script.

Insert contained scripts as "callScript" -- Available when a project is selected, displays a message that enables you to choose Yes or No . Yes inserts a callScript command for all scripts in the project, including the selected folder(s) and all subfolders. No inserts a callScript command only for scripts in the selected folder(s). See Calling a Script from a Functional Test Script.

Merge Objects into -- Displays the Merge Test Objects into the Test Object Map page, which enables you to merge multiple test object maps.

New Folder -- Creates a new folder in the Solution Explorer.

Open -- Opens the selected script in the Code Editor or opens the selected test object map, test datapool, or log.

Properties -- Displays information about the selected Functional Test project, test object map, test folder, script, or test datapool.

Remove -- Enables you to remove the selected project from the solution. To restore the project to the solution, click File > Add Project > Existing Project and select the project from the Add Existing Project dialog box.

Rename -- Enables you to change the name of the selected Functional Test script or test asset.

Reset Custom References -- Synchronizes the .NET .DLL files (Assembly) in the Customization folder with the Functional Test Visual Basic project references. For information, see the online Product Documentation for Visual Basic.

Run -- Plays back a selected Functional Test script.

Set as Startup Project -- Sets the project selected in the Solution Explorer as the one to be first built, debugged, and run first when a solution is deployed. If you have more than two projects in one solution, you must set one of them as the startup project before you can run a script.

Set as Project Default -- Indicates the selected test object map as the default in a variety of wizards and dialog boxes, such as the Select Script Assets page of the Record New Functional Test Script, the Add Empty Functional Test Script wizards, and the Copy Test Objects to New Test Object Map page of the Create New Test Object Map wizard.

Show History -- Displays the previous versions of the script.

View Code -- Opens the selected script for editing in the Code Editor.

Note: If you want to simplify the Visual Studio .NET user interface, you can click the My Profile tab on the Start page, select Student Window Layout in the Window Layout list, and select (no filter) in the Help Filter list. The Solution Explorer and Dynamic Help display on the left side and the Script Explorer displays on the right side of the Visual Studio .NET window. To return to the default Visual Studio .NET user interface, click the My Profile tab on the Start page, and select Visual Studio Developer in the Profile list. In the product menu, click View > Script Explorer.

To open: HCL OneTest UI automatically displays the Solution Explorer (by default) in the Visual Studio .NET window.

Related Topic:

About the Visual Studio .NET Window

Feedback