Test Object Map menu

This topic describes each of the options on the test object map menu.

File menu options

The File menu has the following commands:

Save -- Saves your changes to the test object map.

Revert -- Restores the map to the version last saved.

Checkout -- If the test object map is checked in, checks the map out of ClearCase. If the test object map is private, HCL OneTest™ UI checks out the script too. If the test object map is shared, HCL OneTest UI just checks out the map and not the script.

Renew All Names in Associated Script(s) -- Renews all the names of script test objects in associated script(s).

Exit -- Closes the test object map.

Edit menu options

Cut -- Removes properties selected on a property set tab to a local Clipboard.

Copy -- Copies properties selected on a property set tab to a local Clipboard.

Paste -- Inserts properties previously saved to a local Clipboard at the cursor location property set.

Delete -- Depending on which pane has focus, deletes the selected test object from the test object map or deletes properties from the property set.

Find menu options

Quick Find -- Opens the Quick Find dialog box, which enables you to search for a test object based on a string you specify.

Find by Filters -- Opens the Set Active Find Criteria dialog box, which enables you to select the filter to use for searching the test object map or to create a new filter.

Find & Modify -- Opens the Find & Modify dialog box, which enables you to do either a Quick Find or a Find by filters and make modifications to the results.

Find Used -- Finds all the test objects that have references in the scripts associated with a shared test object map.

Find Not Used -- Finds test objects that have no references in scripts associated with the test object map.

Delete All Not Used -- Opens the Delete All Not Used Test Objects dialog box, which enables you to selectively delete test objects that do not have references in the script associated with the test object map.

First -- Moves to the first test object in the hierarchy that matches the search criterion. The default criterion is State Not Clean, which searches the test object map for all objects that have a New state. For information, see Searching for Objects in a Test Object Map.

Previous -- Moves to the previous test object in the hierarchy that matches the search criterion. The default criterion is State Not Clean, which searches the test object map for all objects that have a New state. For information, see Searching for Objects in a Test Object Map.

Next -- Moves to the next test object in the hierarchy that matches the search criterion. The default criterion is State Not Clean, which searches the test object map for all objects that have a New state. For information, see Searching for Objects in a Test Object Map.

Last -- Moves to the last test object in the hierarchy that matches the search criterion. The default criterion is State Not Clean, which searches the test object map for all objects that have a New state. For information, see Searching for Objects in a Test Object Map.

Test Object menu options

Insert Object(s) -- Opens the Insert a GUI Object into the Object Map dialog box, which enables you to select test objects to Adding objects to a test object map and make them available for scripts.

Update Recognition Properties -- Enables you to update the recognition properties of a test object frame in the application-under-test.

Description Property -- Opens the Set Description Property dialog box, which enables you to Adding test object descriptions. HCL OneTest UI adds the description to the Administrative property set tab for the object and displays the description when you place the cursor over the object name in a script.

Add to Script script -- Adding test objects to a script, which enables you to add it to the script and select a method. HCL OneTest UI changes this menu item to Add to Multiple Scripts to indicate that multiple scripts have been selected and are affected by the command.

Associated Scripts -- Displays a list of scripts that are associated with the test object map.

Accept Node -- Changes the state of the selected test object from New to "Clean."

Accept All -- Changes the state of all test objects from New to "Clean."

Highlight -- Locates the test object in the application-under-test, if visible. If HCL OneTest UI finds more than one instance of the test object, you can display neither or the top two candidates.

Renew Name in Associated Script(s) -- Renews the name of an individual script test object in associated script(s).

Preferences menu options

Toolbars -- Enables you to display or hide the File, Edit, Find, TestObject, Applications, Display, and Help toolbars.

Test Object Description -- Opens the Edit Test Object Description dialog box, which enables you to customize the text displayed for each object in the Test Object Hierarchy.

Clear State on Close -- Accepts all test objects in the test object map by changing their state from New to "Clean" when you close the map.

Highlight -- Opens the Set Highlight Window Preferences dialog box, which enables you to specify how to emphasize objects in the application-under-test when you select them.

Applications menu options

Run -- Opens the Start Application dialog box, which enables you to start a specific application and add test objects to the test object map.

The Applications menu also lists up to nine of the most recently used applications. A number appears next to each application on the menu, which enables you to select an application by typing the number that corresponds to the application. You can also click the application name at the bottom of the Applications menu. 

Display menu options

Expand All -- Displays all test objects in the hierarchy.

Collapse to Selected -- Closes all test objects in the hierarchy except in the selected tree.

Toggle Orientation -- Switches between displaying the property sets under or next to the Test Object Hierarchy.

Help menu options :

Test Object Map Help -- Displays Help for the test object map.

Insert Test Object Help -- Displays Help for adding objects to a test object map.

New Test Object Help -- Displays Help that describes how to set the option to display the test object map for a new object.

Feedback